Connection issues

Incident Report for Cash App Staging

Resolved

This issue has been resolved. Payments, Cash Card transactions, and cash outs are working normally. If you experienced a failed transaction, please try again. Thank you for your patience.
Posted Aug 26, 2026 - 20:24 UTC

Investigating

We're investigating reports of issues with Cash App services. Some customers may experience issues with payments, Cash Card transactions, and cash outs. We'll provide updates as we learn more
Posted Aug 26, 2026 - 20:07 UTC
This incident affected: Cash Card.